Free Downloads - PhotographyUNcapped.com
 

MAC Attack Apple Digital Camera Compatibility Update 2.7

MAC Attack Apple Digital Camera Compatibility Update 2.7

Apple has released an update to their Digital Camera Raw Compatibility 2.7, or at least it’s been announced. At th4e time of this writing, the download still doesn’t appear on their support page. The previous Digital Camera RAW update 2.6 is still showing.

Good Deal from Amazon on a Apple MacBook MC207LL/A 13.3-Inch Laptop

DESCRIPTION
About Digital Camera RAW Compatibility Update 2.7This update extends RAW image compatibility for Aperture 2, iPhoto ’08 and iPhoto ’09 for the following cameras:

  • Canon EOS-1D Mark IV
  • Canon EOS 7D
  • Canon PowerShot G11
  • Nikon D3S
  • Nikon D300S
  • Nikon D3000
WHAT’S NEW
Version 2.7:This update extends RAW image compatibility for Aperture 2, iPhoto ’08 and iPhoto ’09 for the following cameras:

  • Canon EOS-1D Mark IV
  • Canon EOS 7D
  • Canon PowerShot G11
  • Nikon D3S
  • Nikon D300S
  • Nikon D3000
REQUIREMENTS
  • Mac OS X 10.4.11 or later.
  • Aperture 2, iPhoto ’08, or iPhoto ’09

Great Amazon Price on the Apple iPod nano 8 GB Purple (5th Generation) NEWEST MODEL

My Shiny Mac Apple Shot in Digital Infrared

My Shiny Mac Apple Shot in Digital Infrared

Some buzz on the Mac blogs is that Apple is continuing to be a bit slow on these updates, citing that the Nikon D300s has been out for some time. Many Aperture users I hear from have a love/hate thing going on with Apple about this.
Your thoughts? Comment below.

Got the Apple iPod touch? 8 GB (3rd Generation) NEWEST MODEL

  2 Responses to “Apple Releases Digital Camera Raw Compatibility Update 2.7”

  1. HA! And you said the apples were for me to have a little snack at school. I should have known it was photo-related, and not for my health and happiness after all!!!!!!!!!!!

 Leave a Reply

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

(required)

(required)