Free Downloads - PhotographyUNcapped.com
 

Adobe Over Firefox - Battle of the Logos

Adobe Creative Suite 5 and other Adobe CS5 software will require Firefox browser to be closed during installation.

Adobe’s Eric Wilde has posted this on the Adobe Installation and Licensing blog.

Adobe Installation and Licensing: Closing Firefox to Install Adobe Creative Suite.

He lays the reasons and goes on to say: “This all applies to future Adobe Creative Suite retail releases. (sic: CS5, CS6, etc.) CS3 and CS4 installation will not receive the changes mentioned above and will still need browsers to quit.”

For more info on Adobe CS5 see Adobe Photoshop CS5 News Features Release Date Cost Updates.

Subscribe to PhotographyUncapped by Email for continuing updates.

  One Response to “Adobe CS5 Creative Suites and Apps Will Require Firefox to be Closed During Installation”

 Leave a Reply

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

(required)

(required)